1

I'm kind of new to this world, I'm trying to install this dsp correction since I used Equalizer APO in windows and now I'm trying to use it but with no success. This is the rep: https://github.com/bmc0/dsp/wiki/System-Wide-DSP-Guide I followed all the instructions but when I type this command

pacmd load-module module-ladspa-sink sink_name=dsp master=alsa_output.pci-0000_00_14.2.analog-stereo plugin=ladspa_dsp label=ladspa_dsp.

I get this:

Module load failed.

I really don't know what I'm doing wrong, but I'll be glad to provide more info if you want me to. Thank you very much.

2

I recently tried to follow that guide you linked and failed as well. The problem, as it was for me, is probably a misplaced or misconfigured config file.

You should check that you have the file named config (without an extension) in the right folder (/home/USER/.config/ladspa_dsp/), and create it if it's not there. Then try running listplugins: at the beginning you should see something like this:

/usr/lib/ladspa/ladspa_dsp.so: ladspa_dsp (2378/ladspa_dsp)

Don't worry about the LADSPA_PATH warning, it's not important.

Next you have to check the contents of the config file. In my case, the input_channels=2 was missing, and after fixing that everything worked. Try to use the simplest config possible at first, e.g. the example reported in the guide.

If this doesn't work, it would be useful to have a more verbose output of the error. It can be obtained by modifying the default.pa as in the guide file and running pulseaudio -v.

  • 2
    Holy cow!, thank you so much.It was indeed the config file that was in txt. I changed it in the etc folder and then the plugin was loaded correctly. Also my speakers was the same as the demo file so no prob with the input channels. Cheers! – Jorge Francisco Cortés López Feb 18 '18 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.