1

Recently (after recent updates) I noticed that I am seeing some freezing.

To replicate:

1- Boot up desktop PC with GeForce GTX 750 card, 32 GB of RAM and an Intel Core i7-2600 CPU @ 3.40GHz CPU.

2- Everything loads fine. Let PC sit for a few minutes just in case. Then try to launch Applications menu - five second or more delay. Type text into Applications menu - 7 to 10 second delay. Right click anywhere in Firefox - 10 second delay. So then I tried epiphany - right clicking works great, yet launching the epiphany settings/etc has that same delay.

3- Launch a keyboard launcher (previously closed) like synapse. Apps launch right away. Launch Chrome, terminal, Files browser - zero delays. Works great.

4 - Tried this with htop and glances running - nothing spiking or showing up that seemed odd. Nothing standing out in the logs, either.

So here's the tltr.

Ran updates, menu, Firefox right clicking all have delay - Chrome, synapse, terminal, Files do not. It's not hardware as it's replicatable and persistent only with some elements of the desktop.

Any way I can narrow down what the cause is? Tried multiple kernels and don't believe it's the video card.

  • Confirming this seems to affect stuff that is gtk related and certain elements of the desktop. – Matt Hartley Feb 14 '18 at 1:30
1

Solved it. Well, basically with some tough love.

I purged a LOT (but not critical stuff) of my ~./config and ~./local directories and I also purged my ~./mozilla directory. My gut tells me the culprit was a combination of the group of these configs.

Some things to note - I use a dedicated home partition. So this means when I did a clean install using the same dedicated home, the problem persisted.

After cleaning out what I described above (and understanding what data would be gone and what would not), things worked just fine.

  • Way cool! Would this be a possible topic for a future video by any chance? – linux_tim Feb 14 '18 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.