7

I'm new with elementary OS but I have used ubuntu for a while before. I was trying to install Steam and I had a problem, I had to install a lib of 32bits (ia32-libs) and all good, but today, I was trying to install RVM to install Ruby and RoR, and for install it, I get an error while doing apt-get update (I read about it in Stack Overflow), and I have some errors:

Err http://ppa.launchpad.net trusty/main amd64 Packages 404  Not Found
Err http://ppa.launchpad.net trusty/main i386 Packages 404  Not Found
W: Imposible obtener http://ppa.launchpad.net/compiz/ppa/ubuntu/dists/trusty/main/binary-amd64/Packages 404  Not Found
W: Imposible obtener http://ppa.launchpad.net/compiz/ppa/ubuntu/dists/trusty/main/binary-i386/Packages 404  Not Found
W: Imposible obtener http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/source/Sources 404  Not Found
W: Imposible obtener http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-amd64/Packages 404  Not Found
W: Imposible obtener http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-i386/Packages 404  Not Found

I tried with synaptic I get it:

Imposible obtener http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/source/Sources 404  Not Found
Imposible obtener http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-amd64/Packages 404  Not Found
Imposible obtener http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-i386/Packages 404  Not Found
Algunos archivos de índice fallaron al descargar. Se han ignorado, o se han utilizado unos antiguos en su lugar

Sorry the messages are in Spanish. "imposible obtener" == "Imposible to get"

"algunos archivos de indice fallaron al descargar. Se han ignorado o se han utilizado unos antiguos en su lugar" == "Some files of index fail at downloading. They are ignored or used olders"

I read that they are problems with repositories, tried commands like "apt-get autoclean and more, and I used deborphan who say what repositories are useless (I think) and I purge it with sudo apt-get --purge remove $(deborpahn) but the errors don't disappear.

Can I restore all the repositories to the default state? Or how can I solve these errors?

8

You have a couple of PPAs which appear to no longer exist. Both of these PPAs (from compiz and versable) are not default elementary software sources.

You can remove software sources with the "Software & Updates" configuration tool. This is accessible either by searching for it in Slingshot or by opening Software Updater and selecting "Settings..." in the bottom left corner.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.