I have a Dell XPS 13 from 2016. The F7 key is unused. The other F-keys are bound to xf86 keys.

I want to turn my F7 key into a screen off key, running

xset dpms force off

but custom shortcuts can't use just 1 key. In dconf-editor, I manually changed the keybinding for this custom shortcut to F7, but it's still unrecognized.

Using xbindkeys to check the tag for F7, I see that F7 is indeed correct. However, after manually changing the setting in dconf-editor, xbindkeys doesn't detect a keypress for F7 key.

Any ideas? Thanks in advance for your help.

Edit: I'm running Loki, everything up to date.

Try Applications --> System Settings --> Keyboard --> Shortcuts

Select the Custom set on the left, then click the '+' button. Enter the command and options you want to run and then click where it says Disabled. Hit the F7 key and you should see it says F7 instead of Disabled.

You need to log out and back in for this to take effect (as it says at the top).

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.