0

I have a laptop HP Pavilion with Realtek wifi card.

It didn't have a driver for Linux until end of last year as you can see here. Then I installed it when it was released from this repo

It worked fine until I upgrade from kernel 4.13.0.25

Now if I try to go any kernel newer than that nothing on my network works. If I open the network settings it says I'm in Airplane mode. No Ethernet, no wifi, nothing.

I've tried to uninstall/reinstall the driver from newer kernels, still not working.

dkms status output:

bbswitch, 0.8, 4.13.0-16-generic, x86_64: installed
bbswitch, 0.8, 4.13.0-21-generic, x86_64: installed
bbswitch, 0.8, 4.13.0-25-generic, x86_64: installed
bbswitch, 0.8, 4.13.0-26-generic, x86_64: installed
bbswitch, 0.8, 4.13.0-31-generic, x86_64: installed
bbswitch, 0.8, 4.13.0-32-generic, x86_64: installed
bbswitch, 0.8, 4.15.0-041500-generic, x86_64: installed
bbswitch, 0.8, 4.4.0-108-generic, x86_64: installed
bbswitch, 0.8, 4.4.0-109-generic, x86_64: installed
bbswitch, 0.8, 4.4.0-112-generic, x86_64: installed
mt7630e, 2.1.0, 4.13.0-16-generic, x86_64: installed (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!)
ndiswrapper, 1.60, 4.13.0-25-generic, x86_64: installed
ndiswrapper, 1.60, 4.13.0-32-generic, x86_64: installed
nvidia-387, 387.34, 4.13.0-25-generic, x86_64: installed
nvidia-387, 387.34, 4.13.0-32-generic, x86_64: installed
rt3290sta, 2.6.0.0, 4.10.0-40-generic, x86_64: installed
rt3290sta, 2.6.0.0, 4.10.0-42-generic, x86_64: installed
rt3290sta, 2.6.0.0, 4.4.0-101-generic, x86_64: installed
rt3290sta, 2.6.0.0, 4.4.0-103-generic, x86_64: installed
rt3290sta, 2.6.0.0, 4.4.0-104-generic, x86_64: installed
rt3290sta, 2.6.0.0, 4.4.0-108-generic, x86_64: installed
rt3290sta, 2.6.0.0, 4.4.0-109-generic, x86_64: installed
rt3290sta, 2.6.0.0, 4.4.0-112-generic, x86_64: installed
rtl8723de, 5.1.1.8_21285.20171026_COEX20170111-1414, 4.13.0-32-generic, x86_64: installed

Any idea what could be causing this issue?

  • 1
    Please edit the question to include results from terminal for dkms status – Jeremy31 Feb 3 '18 at 13:13
  • @Jeremy31 Done! – danielfranca Feb 5 '18 at 11:40
1

WiFi issues can be a real pain. In reading your post, the card model rang a bell with me and an issue I had read about. This is not my solution in any way but rather one that I read about elsewhere. The instructions cover a card ending in 'BE' but I believe this fix will work or at least, get you moving in the right direction. I have altered the instructions to reflect your card.

There is a simple solution put forth in the article. This is to "provide non-default option for the kernel module that governs the wireless card" per the article.

You will want to open the /etc/modprobe.d/rtl8723de.conf file in a text editor, with sudo or root permissions and add a single line then save the file and reboot. Once the above is open, add this to the file:

options rtl8723de fwlps=N ips=N

Again, once the above is added, save the file then reboot. If this solution works, once you've rebooted, wireless should be working and solid.

Of course, there is another option which would be to update to a newer kernel such as 4.15 but I would try the above first as it is a less time consuming attempt to fix the issue.

Please comment back and share your results.

Good Luck!!!!!

  • hey, Thanks. I've tried your solution, but still not working. I don't know if it helps, but I didn't have a rtl8723de.conf, so I'd created one and added this line. But no success. As a workaround for now I'm always booting in kernel 4.13.0.25 Any newer kernel (up to 4.13.0.32) I get no network at all, no ethernet either, Elementary says I'm on Airplane mode even. – danielfranca Feb 1 '18 at 20:46
  • That's kinda sucks... Another option, like I noted, would to update the kernel. UKUU (Ubuntu Kernel Update Utility) is very useful in doing accomplishing this. If interested, here's a link: omgubuntu.co.uk/2017/02/… – linux_tim Feb 1 '18 at 21:07
  • Thanks for the link, I've upgraded the kernel to 4.15... Now it doesn't say I'm on airplane mode anymore... but still not working :| – danielfranca Feb 5 '18 at 11:41
  • Are you still lacking both WiFi and Ethernet? Also, with no working internet connection, how did you upgrade to the newer kernel? – linux_tim Feb 5 '18 at 15:20
  • Yes, still no internet connection. The wifi works if I stick with kernel 4.13.0.25 (the workaround I'm doing), any kernel after that I don't get wifi/ethernet. – danielfranca Feb 5 '18 at 15:22
1

Maybe in visual mode you can check in the Apps window, start typing Software and it will show something like Software & Updates. It is on the upper-left corner.

For me, in the 5th tab, it shows Additional Drivers and from there I could select an unknown device to use dkms source for the r8812au network driver. (mine is 8812au, but well, choose whichever you need).

Hope this helps from a clean install and without internet. If you can, just connect it with a cable or another USB adapter and spare yourself the hassle by doing this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.