2

I'm looking for a way to have bluetooth turned off every time I start my computer, but without loosing ability to turn it on again using only switch in wingpanel.

I've seen many answers to similar questions recommending adding rfkill block bluetooth to /etc/rc.local but then I can't turn it on using switch, I have to manually unblock it.

A few answers said to change InitiallyPowered option in /etc/bluetooth/main.conf but I don't have that option in that file, and adding it manually didn't work.

Any suggestions would be appreciated.

1

Because of where I use my laptop at times, I also needed to have the machine boot with Bluetooth off. Here is how I did it:

  1. I installed dconf-editor. This can be done via the AppCenter or at a command line by typing sudo apt-get install dconf-editor then entering your password.

  2. Open dconf-editor from the app menu.

  3. Navigate to org-> pantheon-> desktop-> wingpanel-> indicators-> bluetooth

Once you're there, you should see only one listing named "bluetooth-enabled" with a check mark in the value field. Simply un-check the box then close dconf-editor and reboot. After a reboot, you should see that the Bluetooth Icon is still on the panel but it is not enabled by default. You can click on the icon and enable when it's needed.

Hope this helps!

P.S.-Be very careful using dconf-editor as it does allow a user to make a huge number of changes and some changes can have a negative consequence in that you can do serious damage to your system. I learned that the hard way some years ago!

1

So thanks to Porshe Man's answer I have noticed interesting thing. dconf option named bluetooth-enabled stores the current value of bluetooth switch just for the purpose of setting that state at the next start, so there's no need to edit dconf, just using the toggle will do exactly the same thing.

However it doesn't work (at least for me) when I use the restart option. When I reboot my computer by shutting it down and then turning it on again it works just fine. This is the reason I thought I need some special solution - when I wanted to see if bluetooth state is remembered I used restart option.

It looks like it's not a big problem, I will just not use restart option but I guess this behavior is a bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.