6

Right now my UI is without wingpanel. I using stable ppa.

Log:-

$ wingpanel
[_LOG_LEVEL_INFO 23:17:05.546919] Application.vala:155: Wingpanel version: 0.3.0.2
[_LOG_LEVEL_INFO 23:17:05.546998] Application.vala:157: Kernel version: 3.16.0-43-generic
[_LOG_LEVEL_WARN 23:17:05.551314] Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-NGnsKDnTTM: Connection refused
[_LOG_LEVEL_WARN 23:17:05.612371] [GLib-GObject] cannot add interface type 'GeeIterable' to type 'SynapseResultSet' which does not conform to prerequisite 'GeeTraversable'
Segmentation fault (core dumped)

After these were updated:- http://i.imgur.com/y23XARg.png

Bug reported

  • In case you use other PPAs and software from them, could you post them as well? – quassy Aug 22 '15 at 14:54
  • I have the same problem and accepeted solution does not work – stallingOne Sep 14 '16 at 16:33
2

This could very well be caused by indicator-synapse (a 3rd party search indicator similar to Spotlight on OSX) which frequently poses a problem with Freya. Try to uninstall it by typing:

sudo apt-get remove indicator-synapse

and restart your machine:

sudo shutdown -r now

This is in fact a bug of Synapse, not WingPanel. If you have installed Synapse from a PPA and don't need it for anything else I would strongly suggest removing this PPA as well.

Use Synapse anyway

If you want to use Synapse anyway, you can try to install it from this PPA, after completing the steps from above. Be aware, it is called "unstable" for a reason:

sudo add-apt-repository ppa:elementary-os/unstable-upstream
sudo apt-get update
sudo apt-get install indicator-synapse
  • Or rather use this PPA: ppa:yunnxx/elementary – SeasonedNoob Sep 25 '15 at 21:58
  • E: Unable to locate package indicator-synapse – stallingOne Sep 14 '16 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.