0

Originally, I was just having trouble installing updates, but in my attempts to fix that, it would seem I am unable to install anything at all. Anytime I try to install something, I get the same list of unmet dependencies and nothing ends up getting installed. Here's what I get when I try to update from the terminal:

sudo apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
aptitude:i386 : Depends: libapt-pkg4.12:i386 (>= 0.8.16~exp12ubuntu6) but it is not installable
         Depends: libboost-iostreams1.46.1:i386 (>= 1.46.1-1) but it is not installable
         Depends: libcwidget3:i386 but it is not installable
         Depends: libept1.4.12:i386 but it is not installable
         Depends: libncursesw5:i386 (>= 5.6+20070908) but it is not installed
         Depends: libsigc++-2.0-0c2a:i386 (>= 2.0.2) but it is not installable
         Depends: libsqlite3-0:i386 (>= 3.6.5) but it is not installed
         Depends: libxapian22:i386 but it is not installable
         Recommends: apt-xapian-index:i386 but it is not installable
         Recommends: libparse-debianchangelog-perl:i386 but it is not installable
libgl1-mesa-dri : Depends: libdrm-amdgpu1 (>= 2.4.89+git1801130630.fd9bcb~oibaf~x) but 2.4.83-1~16.04.1 is installed
libgl1-mesa-dri:i386 : Depends: libdrm-amdgpu1:i386 (>= 2.4.89+git1801130630.fd9bcb~oibaf~x) but 2.4.83-1~16.04.1 is installed
mesa-vdpau-drivers : Depends: libdrm-amdgpu1 (>= 2.4.89+git1801130630.fd9bcb~oibaf~x) but 2.4.83-1~16.04.1 is installed
ppa-purge : Depends: aptitude
E: Unmet dependencies. Try using -f.

I've tried -f install to correct these, but it fails and returns the same list of dependencies. Thanks in advance for any help.

  • You probably have a mess in the repositories, list them with apt-cache policy. Also give us more info apt-cache policy aptitude:i386,apt-cache policy libgl1-mesa-dri, apt-cache policy libgl1-mesa-dri:i386, apt-cache policy mesa-vdpau-drivers and lsb_release -a – Sebastian Nov 25 '18 at 6:10
0

Answer is in the error. Run sudo apt-get -f install

|improve this answer|||||
  • This does not fix it. I get the same list of unmet dependencies with a different error at the bottom saying: E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. – Curtis Balz Jan 28 '18 at 21:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.