elementary os hasn't been able to update for a long time now. Apt get update works, but i get a bunch of 404 errors. The errors are only for arm64 packages and im on an AMD64 system so i havnt been thinking much of that. Pulseaudio however stopped working, so i tried to purge then re-install it and now i get this error:

Reading package lists... Done Building dependency tree
Reading state information... Done Package pulseaudio is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'pulseaudio' has no installation candidate

i stupidly then decided to purge and reinstall alsa, but same error is thrown.

I have tried removing (backed up first) my sources.list and using additional drivers to create a new one, but still no luck with installing pulse.

I even added the ubuntu-audio-dev-ubuntu-ppa and the ubuntu-audio-dev-pulse-testing-xenial ppa but same error is thrown when i try to do sudo apt-get install pulseaudio.

I was stuck on linux kernel 4.10, but i manually updated to 4.11 to try to get my cpu temps read by the system with no luck.

Im on ubuntu 16.04.3 and apt-get update and apt-get upgrade and apt-get dist-upgrade don't show any updates available.

App center doesn't show any updates either.

I'm also pretty sure there should be a new AMD microcode update available for me, i'm on version 2.??

I have no idea where to begin fixing this because I have tried very many PPA's and mirrors etc from command lie and additional drivers gui, with no changes in results.

Thanks for any help!

1 Answer 1


i fixed it by removing armhf using dpkg and restoring my apt directory by copying the entire folder from clean install media.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.