followed posts from Bulletmark and Neal Fennimore

I can't get multi touch gestures working for desktop shifting.

My process

git clone http://github.com/bulletmark/libinput-gestures
cd libinput-gestures
sudo make install
sudo apt install libinput-tools xdotool
sudo gpasswd -a $USER input
libinput-gestures-setup autostart


sudo apt-get xdotool wmctrl

Then I copied the conf file

sudo cp /etc/libinput-gestures.conf ~/.config/

The edited that file

sudo nano ~/.config/libinput-gestures.conf

Added the following on the bottom,

gesture swipe down 3 xdotool super+Down
gesture swipe left 3 xdotool super+Left
gesture swipe right 3 xdotool super+Right

After saving the file, restarting or logging off and then logging back in I don't get any workspace changing on gesture.

My trackpad is capable, it two finger scrolls well.

When I open the keyboard map its noted that my left windows button is listed as 'Super L' and when I try to remap the workspace shifter keyboard shortcut it thinks my left windows key is Super L and displays the Mac command button icon.

This all seems good compared to what others have posted, but I can't get it to shift workspaces.

Ideally I'd want 3 fingers swiping left and right to shift workspaces left and right and then 3 fingers swipe down to open the exploded multitasking view.



2 Answers 2


Working fine for me on Juno 5.0. Just changed key codes:

gesture swipe down 3 xdotool key super+Down
gesture swipe right 3 xdotool key super+Left
gesture swipe left 3 xdotool key super+Right

I have just followed the instructions on https://neal.codes/blog/adding-mac-like-touch-gestures-to-elementary-os , I have tested everything except the chapter "Better tap to click" and it works perfect for me.

The only difference I found compared to the instructions you did is libinput-gestures-setup restart - you have autostart. I have tried with start also and it works fine, probably you have to try one of these options. Also in order to work you have to log-out>log-in after you add yourself into the input group - this was a notice I read on the shell when I have tried libinput-gestures-setup start before logging out.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.