0

I have a 2GB usb stick which I used to create a bootable Elementary OS (Loki), using Etcher (for Mac) as instructed.

After installing Loki on a HP Pavilion DV7, I encountered suspend issue, Loki can't get up from sleep on this one, so I wanted to try with Ubuntu.

I used the same USB stick and Etcher, to create bootable Ubuntu 16. Etcher created it but was unable to verify it, and I got an error.

Since then, I ended up with a broken USB stick which appears to have 8MB now instead of 2GB. I cannot format it, I cannot make it work.

I tried "diskutil" on a Mac, but cannot erase it, cannot creaty any partitions due to lack of space as it only shows 8MB.

I tried "diskpart" on a PC, tried to "clean" it, no luck, still 8MB, raw space, nothing else.

I tried "gparted" on Linux, and all I see is unallocated 8MB.

screenshot

I've got years of experience with computers, but never had such problem, and I've no idea what to do it this point. Does anyone have an idea how to fix this? I'd really appreciate some help. Thanks

ADDITIONAL INFO:

Output from df -h on Linux:

Filesystem Size Used Avail Use% Mounted on udev 220M 0 220M 0% /dev tmpfs 49M 2.9M 46M 6% /run /dev/sda1 63G 3.8G 56G 7% / tmpfs 241M 144K 241M 1% /dev/shm tmpfs 5.0M 4.0K 5.0M 1% /run/lock tmpfs 241M 0 241M 0% /sys/fs/cgroup tmpfs 49M 44K 49M 1% /run/user/1000

Output from lsblk on Linux:

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT sdb 8:16 1 8M 0 disk sr0 11:0 1 1024M 0 rom
sda 8:0 0 64G 0 disk ├─sda5 8:5 0 510M 0 part [SWAP] └─sda1 8:1 0 63.5G 0 part / sr1 11:1 1 1024M 0 rom

Output from diskpart list disk on Windows:

Disk ### Status Size Free Dyn Gpt Disk 0 Online 64 GB 0 B Disk 1 Online 8 MB 0 B

Output from diskutil list on a Mac:

/dev/disk3 (external, physical): #: TYPE NAME SIZE IDENTIFIER 0: *8.4 MB disk3

  • Have you tried 'diskpart' on windows PC? – Ravan Jan 15 '18 at 15:31
  • I'm not sure if you read my post - but I said "I tried "diskpart" on a PC, tried to "clean" it, no luck, still 8MB, raw space, nothing else." – waveman Jan 15 '18 at 15:33
  • I don't have the habit of throwing a comment with out reading the post... btw "a PC"? what is the OS of that PC? Have you installed elementary OS? what is output of df -h – Ravan Jan 15 '18 at 15:44
  • Also lsblk output – Ravan Jan 15 '18 at 15:54
  • I just wanted to clarify, since you asked about a PC. I used "diskpart" which is a windows software, so I clearly used windows. I tried in 7 & 10, but there is no difference obviously. – waveman Jan 15 '18 at 16:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.