1

This question already has an answer here:

I noticed recently a rather low performance in 3D games that are usually very little demanding for my machine, such as Team Fortress. This game can be run with no issues using only one of the GPUs, and it runs just fine, but lately I've been noticing big frame drops when there was a lot of shots or characters fighting on screen. I then came to realize that my laptop is getting damn hot. Also, after rebooting into Windows, the fans kick in at maximum power for a bit until temperature lowers down. So fans seem inactive at Elementary. What can I do to enable/check on them? Is there any GUI controlling tool?

Edit: Current Kernel: 3.16.0-46-generic.

Thank you!

marked as duplicate by r3bl, John Guerreiro, Rafael, Lewis Goddard Aug 25 '15 at 17:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Which kernel version are you using? Please, add the output of uname -r to your question. – Rafael Aug 21 '15 at 11:53
  • You should probably check out this question. Although it's technically about battery life and not about overheating, the same tools should be used to fix the problem. – r3bl Aug 23 '15 at 21:51
  • Thanks, but already did that. The fans show permanently at 0rpm. – Timo Aug 24 '15 at 10:46
4

I am assuming you are running on a stock version of Freya with kernel 3.16.
I looked up the internet a bit for your laptop configuration and it seems that you have a NVidia dual GPU. Kernel 3.16 does not support relatively modern Nvidia GPUs (like the GT 755M) properly-because of Nvidia(who BTW Linus Torwalds, the creator of Linux, gave a middle finger...publicly) which does not release the drivers for its models.
So I would not suggest playing games on elementary OS on your configuration. I myself have an AMD discrete GPU and only recently it has got fairly good support on Linux. This is also the reason why your laptop is getting really hot. The Nvidia card without proper drivers support sucks in a lot of unnecessary power causing circuits to get hot and the fan to kick in at full speed. Then when you reboot into Windows, the circuits are still hot and the drivers put adjust the system so that it cools down as soon as possible.
I would suggest(any one of the following, preferably try 3, 2 4,5 ,6 and if nothing works then 1)

  1. Using a Linux distro with a newer Kernel(like Ubuntu 15.04)
  2. Install tlp from here. When installed, open a terminal and activate tlp using sudo tlp start.THis is saved across restarts. When you connect to AC adapter, your laptop will run as it is now. When you remove the AC cable, it will run on low power mode.
  3. Install powertop from the Software Center via sudo apt-get install powertop in the terminal. Then open it- sudo powertop in terminal. Then press Tab number of times till you reach the the Tunablessection. Press Enter to change each option with "Bad" to "Good" and up down keys to navigate the list. When done changing all to "Good", press Esc or Ctrl+c to exit powertop. Everytime you restart, you will have to configure powertop again using the methods in this point(starting from sudo powertop)-the settings are not saved across restarts. Here is the official User Guide on powertop-you don't need to read it though.
  4. Installing Nvidia drivers from their official site after checking all the release notes otherwise if your kernel is not supported, then it could lead to the system unable to boot
  5. Install bumblebee-since I am on AMD, I don't know a lot about Nvidia drivers but I heard about this project on a lot of discussions. Check out this project here. If I were you I would use it with a grain of salt because the drivers seem to be last released in 2013-check if your system(Ubuntu 14.04-elementary OS is based on this) and graphics card are supported
  6. Disable the discrete Nvidia graphics card and use the integrated Intel Graphics card-a little Google search will help
  • 1
    I use the same notebook and I use Freya only with disabled Nvidia graphics card as @cheekyngeeky in option 6 suggested. No problems since ~8 months and I never heard the fan's noise. – mazienho Aug 22 '15 at 22:06
  • Hm...Seems I didn't get saved my edit. 1: I'd like indeed to upgrade to linux-image-3.19, but seems I get a blank screen without reaching the desktop. Any ideas? 2: tlp doesn't seem to be helping, I had it installed before posting, but to no avail. I can see a "fan1" at 0RPM on the app Psensor. 3: What does this do? Modify the apps niceness/priority? 4: Nvidia is up to date, however I need to check which driver is currently installed. 5: Due to a bad Intel/Lenovo mobo design, when the ultrabay is used by an SLI GPU, the intel card is unreachable. So bumblebee isn't an option for me. – Timo Aug 25 '15 at 1:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.