I am not an expert in the terminal but I understand how it works a little. So I wanted to remove some themes from my elementary OS Loki. First I deleted the .theme folder, but on the tweaks I could still see some themes available that I installed.

So in terminal I removed some macOS themes, and then I saw this Adwaita package in Tweaks and I wanted to remove. I run the command:

sudo apt-get remove adwaita-icon-theme 

By removing it, all the icons were removed. I tried to reinstall it then and restart the system. But now I can’t boot in. It’s stacked at the Elementary Logo.

How can I fix my system? Can I do it with a live USB? If yes how?


After google a while I realised that the package is at the core of the gnome desktop environment. And by removing it other packages and libraries were broken, removed. But I still hope for a solution.

2 Answers 2


I managed to log in in the console CTRL+ALT+F1, where I run:

$ sudo apt install --reinstall elementary-desktop

Then when I reboot the os I could see the desktop and a prompt to login. However after I login, I could only see the wallpaper. No dock or status bar were displayed.

I switched back to the console, and I installed the plank and reinstalled pantheon, pantheon-shell, reboot it. And that fixed the desktop environment. Still, some programs were lost, as Videos and Chromium, and some settings were also lost, but most of them were still kept.


Good to know you could at least log in. Just so you get back your old system, here is a list of packages that depend, directly or indirectly, on adwaita-icon-theme:

appcenter apport-gtk audience bamfdaemon capnet-assist dconf-editor elementary-artwork elementary-default-settings elementary-desktop elementary-icon-theme elementary-sdk epiphany-browser evince evolution-data-server evolution-data-server-pantheon-online-accounts file-roller gala gcr gir1.2-appindicator3-0.1 gir1.2-clutter-1.0 gir1.2-granite-1.0 gir1.2-gtk-3.0 gir1.2-mutter-3.0 gir1.2-peas-1.0 gir1.2-rb-3.0 gir1.2-vte-2.91 gir1.2-webkit2-4.0 gir1.2-wnck-3.0 gjs gkbd-capplet gnome-bluetooth gnome-font-viewer gnome-icon-theme gnome-icon-theme-symbolic gnome-keyring gnome-orca gnome-power-manager gnome-session-bin gnome-settings-daemon gnome-user-guide gnome-user-share granite-demo gstreamer1.0-clutter-3.0 gstreamer1.0-plugins-bad gtk-3-examples gvfs-backends humanity-icon-theme ibus ibus-gtk3 ibus-table indicator-application indicator-kdeconnect libappindicator3-1 libcanberra-gtk3-0 libcanberra-gtk3-module libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcheese-gtk25 libcheese8 libclutter-1.0-0 libclutter-1.0-dev libclutter-gst-3.0-0 libclutter-gtk-1.0-0 libedataserverui-1.2-1 libevdocument3-4 libevview3-3 libfolks-eds25 libgail-3-0 libgala-dev libgala0 libgcr-ui-3-1 libgjs0e libgnome-bluetooth13 libgnome-desktop-3-12 libgnomekbd8 libgranite-dev libgranite3 libgranite4 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk-3-dev libgtksourceview-3.0-1 libgtkspell3-3-0 libgweather-3-6 libindicator3-7 libmaya-calendar0 libmutter-dev libmutter0g libnautilus-extension1a libnm-gtk0 libnma0 libnoise-core0 libpantheon-files-core0 libpantheon-files-widgets0 libpeas-1.0-0 libpeas-1.0-0-python3loader libplank1 librhythmbox-core9 libscratchcore0 libtimezonemap1 libunity-control-center1 libunity-settings-daemon1 libvte-2.91-0 libwebkit2gtk-4.0-37 libwebkit2gtk-4.0-37-gtk2 libwebkit2gtk-4.0-dev libwebkitgtk-3.0-0 libwingpanel-2.0-0 libwingpanel-2.0-dev libwnck-3-0 libyelp0 light-locker maya-calendar maya-calendar-daemon maya-calendar-plugin-caldav maya-calendar-plugin-google mousetweaks network-manager-gnome network-manager-openvpn-gnome network-manager-pptp-gnome noise notification-daemon onboard onboard-data pantheon-agent-polkit pantheon-calculator pantheon-files pantheon-greeter pantheon-mail pantheon-online-accounts-plugin-fastmail pantheon-online-accounts-plugin-password pantheon-photos pantheon-print pantheon-shell pantheon-terminal pantheon-xsession-settings pinentry-gnome3 plank policykit-1-gnome python3-aptdaemon.gtk3widgets scratch-text-editor screenshot-tool sessioninstaller slingshot-launcher snap-photobooth switchboard switchboard-gnome-control-center-override switchboard-plug-a11y switchboard-plug-about switchboard-plug-applications switchboard-plug-bluetooth switchboard-plug-datetime switchboard-plug-display switchboard-plug-gcc-color switchboard-plug-gcc-sound switchboard-plug-gcc-wacom switchboard-plug-keyboard switchboard-plug-locale switchboard-plug-mouse-touchpad switchboard-plug-networking switchboard-plug-notifications switchboard-plug-online-accounts switchboard-plug-pantheon-shell switchboard-plug-parental-controls switchboard-plug-power switchboard-plug-printers switchboard-plug-security-privacy switchboard-plug-sharing switchboard-plug-useraccounts switchboard-plug-users system-config-printer-gnome transmission-gtk ubuntu-mono unity-control-center unity-settings-daemon user-specific-alternatives wingpanel wingpanel-indicator-ayatana wingpanel-indicator-bluetooth wingpanel-indicator-datetime wingpanel-indicator-keyboard wingpanel-indicator-network wingpanel-indicator-notifications wingpanel-indicator-power wingpanel-indicator-session wingpanel-indicator-sound xdg-user-dirs-gtk yelp zenity

Try installing these, and most of the stuff elementary OS comes with should be back.

Note: I pulled this list from my installation, and then removed any packages I had installed myself. I'm sorry if I forgot anything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.