0

Solved:

This was solved with an update that was just pushed.

The problem:

I have an XPS 13 (9360) laptop that has an external monitor plugged in through HDMI using a Dell USB-C adapter. Going to Settings->Displays shows the external monitor but enabling it simply gives it a black screen. I can drag my mouse over to the area that was set for the monitor to display in (e.g.: if the monitor was set up to display to the right of me built-in monitor, my mouse could move off the screen to the right). After a few times of fiddling with the display settings, the external monitor would just disappear from the display settings as if it had been unplugged.

The details:

  • This setup has worked fine on every other distro I have using on this laptop.
  • I have tried setting up the external monitor using Arandr as well, with the same issues.
  • The monitor does work when the resolution is lowered by a lot but that is more of a hacky work around than an actual solution, in my opinion.
  • I have also installed all eOS updates and installed the Intel Microcode drivers.

The hardware:

The begging:

Any help you could provide would be greatly appreciated. I really want to continue using eOS but this bug will probably push me back to something else if I can't find a solution.

Solved:

This was solved with an update that was just pushed.

  • If the issue doesn't exist anymore with the latest update, you may put that as an answer and mark it as accepted – Axel Advento Jan 11 '18 at 14:00
  • I put it as an answer but it won't let me accept my own answer for 48 hours after I have made it. – Gort Jan 11 '18 at 20:33
  • Forgot about the grace period, sorry – Axel Advento Jan 12 '18 at 11:19
1

An eOS system update was just pushed and seems to have solved this issue. The monitor now displays with the proper resolution. Setting monitor positions and primary/secondary settings is still really jank but it is possible to work with it until everything is right.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.