1

since a few days I cannot apt update any more, it says

Hit:1 http://repo.steampowered.com/steam precise InRelease
Hit:2 http://de.archive.ubuntu.com/ubuntu xenial InRelease                                                           
Hit:3 http://security.ubuntu.com/ubuntu xenial-security InRelease                                                    
Hit:4 http://ppa.launchpad.net/cybre/sni-qt-eplus/ubuntu xenial InRelease                                            
Hit:5 http://de.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                        
Hit:6 http://de.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                      
Hit:7 http://ppa.launchpad.net/elementary-os/daily/ubuntu xenial InRelease                    
Get:8 http://packages.elementary.io/appcenter xenial InRelease [5.893 B]
Hit:9 http://ppa.launchpad.net/elementary-os/stable/ubuntu xenial InRelease                                    
Hit:10 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial InRelease 
Hit:11 http://ppa.launchpad.net/jonathonf/vim/ubuntu xenial InRelease        
Hit:12 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu xenial InRelease 
Hit:13 http://ppa.launchpad.net/ondrej/php/ubuntu xenial InRelease           
Hit:14 http://ppa.launchpad.net/elementary-os/os-patches/ubuntu xenial InRelease
Hit:15 http://ppa.launchpad.net/teejee2008/ppa/ubuntu xenial InRelease       
Hit:16 http://ppa.launchpad.net/ubuntu-mozilla-daily/firefox-aurora/ubuntu xenial InRelease
Err:8 http://packages.elementary.io/appcenter xenial InRelease                
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A74F73EFFE70B91C
Reading package lists... Done 
W: GPG error: http://packages.elementary.io/appcenter xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A74F73EFFE70B91C
E: The repository 'http://packages.elementary.io/appcenter xenial InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Googling for this tells me I should somehow add the public key but solutions like

$ sudo LANG=C apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A74F73EFFE70B91C
Executing: /tmp/tmp.TzN2XR5fIq/gpg.1.sh --keyserver
keyserver.ubuntu.com
--recv-keys
A74F73EFFE70B91C
gpg: requesting key FE70B91C from hkp server keyserver.ubuntu.com
gpgkeys: key A74F73EFFE70B91C not found on keyserver
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0
gpg: keyserver communications error: key not found
gpg: keyserver communications error: bad public key
gpg: keyserver receive failed: bad public key

do not work as well. Maybe elementary uses another keyserver than ubuntu? Or something else is broken?

AppCenter also aborts with an error message (same reason)

I have read this question but (as above) the solutions provided here do not work in my case

Would be very glad if someone could help, thanks a lot in advance

  • I'm facing the exact same issue. I've trying the approach you found on Google, but still no success at all. :( – Miere Jan 19 '18 at 23:20
  • I just solved my problem by commenting (and backing up) the source entry that was causing the problem. After 'apt update && apt upgrade' successfully, I've restored the backup file, and then I came back to the normal once again! – Miere Jan 19 '18 at 23:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.