6

I try since some days to install and make work ibus on Freya but in not work, I want use it for Vietnamese writing. The layout in the default input methods is not good.

Of some one can give me some clues for make it work it will be amazing.

3

Support for ibus on elementary is not yet complete, but you can still use it with some inconsistencies I just tested it and the only problem was the indicator on wingpanel that didn't update accordingly when switching between different input methods (not a problem if you are only going to use the Vietnamese layout).

You should have ibus-unikey installed, if you don't do it with this command:

sudo apt-get install ibus-unikey

Now configure ibus through ibus-setup. To do this, run the command on a terminal and go to the input method tab.

Check the box beside "Customize active input methods"

enter image description here

Then click the menu below, scroll all the way to the bottom, and select Vietnamese > Unikey.

enter image description here

Finally click on the add button and make sure you left Unikey as the active input method, then close the window.

enter image description here

Now you should be able to type using Unikey. To switch layouts use Ctrl + Space , ( instead of the default Alt + Space ), if you want to change this shortcut then this has to be done from ibus-setup on the General tab and not from the shortcuts GUI on Switchboard.

enter image description here

  • 1
    Dunno why, but doesn't work for japanese. Can not switch layout. Can you help me? Ctrl+Space does nothing. – orkenstein Dec 20 '15 at 9:55
  • Doesn't work for ibus-chewing, either. – JulianLai Jan 9 '16 at 4:34
1

You can do the following to solve the problem-

  1. Install your desired input method for IBus.
  2. Run ibus-setup command from terminal.
  3. Select 'Input method' tab and Add your desired input method.
  4. Close 'IBus Setup' and run ibus-daemon -drx in terminal.

It starts IBus daemon but It doesn't show IBus on the panel, it brings up the input method popup and let us choose our desired input method.

If you want IBus to automatically start with the system, then go to Settings > Applications > Startup and add ibus-daemon -drx as a custom command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.