0

Screenshot that shows that an executable is not "seen" by the system

I am using Loki 0.4.1 on a 64-bit machine. When I try to open an executable, or use a shell script that opens it, the system responds by saying that the given file does not exist. However, the output of ls and file --mime-typeshows that the file is there. This has happened several times with different executables.

Is there a way to fix this? I have tried editing the permissions, but it didn't help...

0

You're sure it has execution rights? (using ls -l would give more information).

$sudo chmod +x wine should give the file execution rights.

  • Also one shoud check mount options. There is noexec mount option that could affect the issue – Alexey Ten Aug 30 '18 at 19:20
0

to run executable files on linux, you have to install wine

$ sudo apt install wine wine1.6 wine1.6-amd64

to check that it's installed run winecfg (a config windows should appear)

to run an executable file we run the command: $ wine file.exe

check Using_Wine

and one note: normally, a file can be launched by ./file if it has #!/bin/bash for bash scripts or #!/usr/bin/env python for python scripts ... otherwise try: $ bash file ... or $ python file

  • and to run skyrim, you need to install directX after installing wine: $ winetricks xact vcrun2008 ... i think also that skyrim exist on steam... and steam can be installed on linux (check in the AppCenter) – mIcHy AmRaNe Mar 3 '18 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.