0

I used ubuntu before where the alexa connects as a speaker and plays audio from the computer. Now I have elementary OS and the alexa connects as a microphone with no option to play sound. I have tried "forgetting" and adding the alexa many times it always shows up as a microphone. How do I make the alexa show up as a bluetooth speaker the way it has worked on ubuntu and osx?

1

First, update your system. This steps probably won't work if you are not using Loki (elementary OS 0.4).

Bluetooth is buggy sometimes. Delete alexa from the Bluetooth settings inside System Settings and reboot your computer. Go back again to the settings menu and press + to add a new bt device.
Now turn on BT on Alexa. When it appears on the menu you've just opened, click on it and accept all windows on both devices until it connects.

Now it should work automatically.


There's a thing called bluetooth profiles for audio. You have A2DP for high quality audio and HSP/HFP for mono audio and microphone.
Basically when you want to use the mic you have to switch to the HSP/HFP profile (you can do it from an option inside Sound Settings). But since Bluetooth is broken in linux, when you want to switch back to the A2DP profile it won't work most of the time.
So I recommend you to just use Alexa as a speaker or as a mic so you don't have that problem. Or follow this guide every time you want to switch back to the A2DP profile, it's up to you.

This bluetooth bug is a upstream issue and it will take a while to fix. It has nothing to do with elementary so please be patient :)

| improve this answer | |
  • This fixes it but now the alexa doesn't show up as a mic. How is it possible to control if the alexa is a mic or a speaker? – user3112731 Dec 29 '17 at 16:20
  • I've updated my post answering your question, check it out :) – Maccer Jan 2 '18 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.