5

I am trying to figure out how to disable the launcher icon bounce in Plank. Please help.

  • I'm not sure this is Freya-specific. Someone more knowledgeable should edit the question to remove that if it indeed is not the case. – waldyrious Aug 20 '15 at 16:29
12

You can create a custom theme that disables the bounce animation by following these steps:

  1. You will first need to create a new directory for the custom theme. It is important that you give it a unique name that does not conflict with any existing theme names.

    mkdir -p ~/.local/share/plank/themes/no-bounce
    
  2. Assuming that you are using the default theme (elementary), make a copy of the theme to your user directory. Other default themes are located in /usr/share/plank/themes.

    cp /usr/share/themes/elementary/plank/dock.theme ~/.local/share/plank/themes/no-bounce/
    
  3. Edit the theme file.

    scratch-text-editor ~/.local/share/plank/themes/no-bounce/dock.theme
    
  4. Look for the line that starts with LaunchBounceTime. Modify it to LaunchBounceTime=0. Save the file and exit the editor.

  5. Open your dock settings to change it to the custom theme.

    scratch-text-editor ~/.config/plank/dock1/settings
    
  6. Look for the line that starts with Theme. Modify it to Theme=no-bounce. Save the file and exit the editor.

Your dock icons should no longer bounce when you launch them.

  • Nice job! Excellent answer! – r3bl Aug 20 '15 at 16:53
  • Excellent Thank You. I got impatient and installed Dockbarx which I wanted to see work with elementary or not. After the next install I do I will follow these directions and work with Plank. Thanks again. – Jason Byrne Aug 21 '15 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.