0

Hi I have just installed Elementary OS Loki 0.4.1, on to my acer aspire 5742 PEW71 laptop. I have it dual booted with windows 7 which can alter screen brightness, however when i change the brightness in windows 7 it does not alter Element OS. It has received all the latest updates and have tried the following:

  1. xbacklight
  2. cd /sys/class/backlight/*/ 
    sudo chmod 777 ./brightness 
    sudo echo $(cat max_brightness) > ./brightness``
    
  • Please include relevant hardware information like computer/laptop, which brand which version etc. – Peter Uithoven Dec 25 '17 at 0:35
  • Hi peter, i have included the laptop model, is there any other information that i can add, that may be of use – Joe Hutchinson Dec 25 '17 at 12:38
  • I would try searching on something like "Acer Aspire brightness ubuntu". (Ubuntu because ElementaryOS is build on it and it's a very common Linux distro) It might be a driver issue. See for example: ubuntuforums.org/showthread.php?t=2200860 – Peter Uithoven Dec 27 '17 at 21:48
0

Originally posted by divergex:

Here is the solution that worked on my Aspire 5740; In the terminal, run:

sudo gedit /etc/default/grub

when the file opens, look for the line similar to:

GRUB_CMDLINE_LINUX_DEFAULT="quite splash"

and add acpi_osi= to the list, so it looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quite splash acpi_osi="

save the file, then exit gedit. Next, be sure to run:

sudo update-grub

to make the changes permanent. Exit the terminal and reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.