it turns out that my laptop had windows and I decided to put linux, specifically Elementary OS.

Even though everything is fine, WiFi does not. The speed is much slower, I have 60mb and in windows I reached 60mb.

Sometimes I have 40-50mb, other times it does not reach 10mb and other times I do not even have wifi, while on my other computer I have the exact 60mb. We do not talk about days, this happens all the time.

I tried everything, install Ubuntu, Deepin, follow internet guides that are useless, but I could not fix it. What can happen?

  • 1
    Just to confirm, you have steady speed of 60Mb on windows, but on elementary the speed fluctuates? And you have tested on other Linux distros and you experience the same issue on those as well?
    – pretz
    Commented Dec 7, 2017 at 16:58
  • Yes, in Windows the connection is perfect. But Linux is going to me fatal, I tested Elementary first, then I tried Deepin and Ubuntu, but none of them went well at all. Very slow speed, connection cuts, it does not connect to the network at times. I reinstalled windows and perfect again, but in Linux no way.
    – pikota
    Commented Dec 8, 2017 at 17:54

1 Answer 1


This guide helped in my case: https://connectwww.com/how-to-solve-realtek-rtl8723be-weak-wifi-signal-problem-in-ubuntu/4625/

My problem was that my wifi card had 2 antennae but only one was plugged in and the linux drivers were using the wrong one. This downloads new drivers and changes the ant_sel option to 2.

git clone https://github.com/lwfinger/rtlwifi_new
cd rtlwifi_new
sudo make install
sudo modprobe -rv rtl8723be 
sudo modprobe -v rtl8723be ant_sel=2

If it doesn't solve the problem, try with sudo modprobe -v rtl8723be ant_sel=1.

If the problem was resolved, then use this command to make the change permanent across reboots:

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf

(or ant_sel=1, as the case may be).

Be aware that some updates replace the above configuration and so you might have to change this periodically. I made a bash script in my home with the above commands (minus the git clone part, of course) and run it when I see that the internet is unbearable slow.

Also, you might want to try disabling bluetooth. For some reason my laptop cannot connect on the internet if BT is enabled.

  • 1
    Thank you! I decided to install elementary again and followed the guide you gave me in the link and it worked. Everything is fine now.
    – pikota
    Commented Dec 20, 2017 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.