I have installed OpenCPN which is navigation software that needs a GPS connection. I used the installation for Ubuntu 17 and the program works however when I try to connect my USB GPS dongle the program requires access to a serial port (because NMEA0183 data sent by the dongle is in serial format) An attempt to make a serial connection brings up a message saying I do not have access to serial ports on this system and tells me to exit and run the following in Terminal " sudo usermod-a-G dialout (followed by my username)". This is not a valid command. How do I get permanent access to serial ports?

1 Answer 1

$ sudo adduser <your_user_name> dialout

You will need to log out and back in again for this to take effect.

  • Thank you for that. I tried it and it told me that I was already a member of dialout! however after a restart it has allowed me to connect the GPS dongle. Problem Solved. Now the problem is to get the dongle to get a GPS fix, but that is a dongle issue, not a Linux one.
    – Norman_E
    Nov 28, 2017 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.