2

ibus is not working in elementary OS Loki though installed and setup as required. Even if the the input changed from English to Avro (a Bengali ibus input) except few applications(Eg. Plume Creator), most of the application is not supporting writing with Avro, instead it is continuing writing in English.

ibus Avro setup instruction https://github.com/sarim/ibus-avro/blob/master/README.md

1

As I can see you already installed iBus Avro now you need to change Input Method Configuration only.

  1. Open Terminal and type

    sudo im-config
    
  2. Select Ok then Yes

  3. Select Ibus as input method for the system

  4. Click Ok and Ok for the next windows. Then restart your computer.

0

I had the same problem, and this anwser worked for me:

Run ibus-daemon -drx in terminal.
If you want IBus to automatically start with the system, then go to Settings > Applications > Startup and add ibus-daemon -drx as a custom command.

0

Add these 3 lines at the end of ~/.profile file. Then logout and login again. Ibus-Avro should work

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

You should add them to ~/.profile instead of ~/.bashrc file, since ~/.profile is sourced during graphical login.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.