After latest updates done trough AppCenter I have following error:

sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up update-notifier-common (3.168.5) ...
Traceback (most recent call last):
  File "/usr/lib/update-notifier/package-data-downloader", line 24, in <module>
    import debian.deb822
  File "/usr/lib/python3/dist-packages/debian/deb822.py", line 47, in <module>
    import six
ImportError: No module named 'six'
dpkg: error processing package update-notifier-common (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have found this: package update-notifier-common 3.168.4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1 but I had 'six' installed before.

I've tried to removing 'six' and installing it again trough 'pip'. It doesn't helped.

Python versions: 2.7.12, 3.5.2, 3.6.3 (also folder named python3 in /usr/local/lib).

OS version: Loki 0.4.1

sudo -H pip install six
Requirement already satisfied: six in /usr/local/lib/python3.6/dist-packages

sudo -H pip2 install six
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages

I don't know how to check it for 3.5.2 and this python3 folder.

2 Answers 2


I encountered the same problem today. After a number of searches on the Stack Overflow site, no desired solution was found. However, I found a solution after searching on a Chinese website, and below are the solution:

cd /var/lib/dpkg
sudo mv info info.bak
sudo mkdir info
sudo apt-get upgrade

Ref here

  • I have no idea why, but this worked for me. Commented Sep 20, 2021 at 16:49
  • This helped be on Ubuntu, related to a apt_pkg missing module error. Commented Mar 20, 2022 at 8:15

The problem was Python 3.5.2.

I've found a different way to install packages with 'pip':

python3.5 -m pip install foo

So I was able to firstly install there 'pip' itself (don't know why I have 'pip' in 2.7 and 3.6 but not in 3.5, my mistake):

python3.5 get-pip.py

and after that:

python3.5 -m pip install six

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.