1

I've always been able to turn the screen off by lowering the screen brightness. The last step would turn the screen off.

But since I recently did a firmware upgrade using fwupdmgr this doesn't work anymore. The screen's brightness simply goes one level lower.

The device which I upgraded:

UEFI-124c207d-5db8-4d95-bd31-34fd971b34f9-dev0
  Guid:                 124c207d-5db8-4d95-bd31-34fd971b34f9
  DisplayName:          XPS 15 9550
  Provider:             UEFI
  Flags:                internal|allow-offline|require-ac
  Version:              0.1.4.0
  VersionLowest:        0.1.4.0
  Created:              2017-10-22
  Trusted:              none

I have a Dell XPS 15 9550 running Loki.

/sys/class/backlight/intel_backlight/brightness contains 1 at the lowest brightness. I can fill it with 0 manually, which does turn the screen off, I just can't do that with my brightness keys.
cat /sys/class/backlight/intel_backlight/max_brightness contains 1500.

Is anyone experiencing the same issue? Is this changeable in configuration maybe?

0

So I wouldn't really call this a solution, more a workaround.

I did some research on how I could control my display, found interesting answers in: https://askubuntu.com/questions/62858/turn-off-monitor-using-command-line xset for example would always turn off all screens. xrandr seemed to also log me out sometimes Both the the above would be canceled on key presses and mouse movement. They also seemed to be overruled by Redshift.

Then I learned about xbacklight from: https://askubuntu.com/a/149265/519324. After a sudo apt install xbacklight I could control the brightness like I hoped. The following would set the brightness (of my main display) to actual 0 and let me turn it up again with my regular brightness meta keys.

xbacklight -set 0

So now I've put that command under the keyboard shortcut: alt+Monitor brightness down.

I couldn't overrule my regular Monitor brightness down, for some reason Disabled would be shown.

I also learned using xbacklight -get that the lowest brightness I could reach with just the brightness meta keys was 0.066667.

A better solution would be to make sure the brightness controlling meta keys could simply lower to 0...

Update: It appears that there have been lot's of discussions on whether screens should turn off at the lowest brightness. https://github.com/mate-desktop/mate-power-manager/issues/179#issuecomment-170062936 There doesn't really seem to be a clear way to configure this...

Update 2: It's been a while, but sadly after a bios update using fwupdmgr the xbacklight command stopped having any effect.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.