1

I have a problem with updating my Elementary OS system.

When I click on the button "update" of the "operating system updates" in the appcenter of Elementary os, the update gets "cancelled". Updating system updates

If I try a second time, it gets cancelled too and I get this strange situation. After updating system updates second time

Then if I try to update in the terminal, I get the message that there are some dependencies not ok.

peter@peter-DP505-DM515:~$ sudo apt full-upgrade Reading package lists... Done Building dependency tree
Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: libperl5.22 : Breaks: libperl5.22:i386 (!= 5.22.1-9) but 5.22.1-9ubuntu0.2 is installed libperl5.22:i386 : Breaks: libperl5.22 (!= 5.22.1-9ubuntu0.2) but 5.22.1-9 is installed perl : Depends: libperl5.22 (= 5.22.1-9ubuntu0.2) but 5.22.1-9 is installed E: Unmet dependencies. Try using -f. peter@peter-DP505-DM515:~$ sudo apt full-upgrade -f Reading package lists... Done Building dependency tree
Reading state information... Done Correcting dependencies... Done Calculating upgrade... Done The following packages will be upgraded: libperl5.22 1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 2 not fully installed or removed. Need to get 0 B/3391 kB of archives. After this operation, 12,3 kB disk space will be freed. Do you want to continue? [Y/n] Y (Reading database ... 304486 files and directories currently installed.) Preparing to unpack .../libperl5.22_5.22.1-9ubuntu0.2_amd64.deb ... Unpacking libperl5.22:amd64 (5.22.1-9ubuntu0.2) over (5.22.1-9) ... dpkg: error processing archive /var/cache/apt/archives/libperl5.22_5.22.1-9ubuntu0.2_amd64.deb (--unpack): trying to overwrite shared '/usr/share/doc/libperl5.22/changelog.Debian.gz', which is different from other instances of package libperl5.22:amd64 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Processing triggers for man-db (2.7.5-1) ... Errors were encountered while processing: /var/cache/apt/archives/libperl5.22_5.22.1-9ubuntu0.2_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) peter@peter-DP505-DM515:~$

Do I have to uninstall something, delete something or install a newer version of an item that is not monitored by the appcenter to be able to get my updates again?

Thanks in advance for the help!

  • I have the exact same issue with the terminal. libperl5.22 is the only package I am unable to upgrade. – maliktunga Nov 15 '17 at 15:11
1

I found this solution here:

sudo rm /usr/share/doc/libperl5.22/changelog.Debian.gz
sudo apt install -f

I hope this fixes it for you too!

0

I had a similar issue today not elementaryOS, but on Ubuntu 16.04, also with amd64 as a foreign architecture. There seems to be a conflict between the two architectures which I don't think should happen.

I just deleted /usr/share/doc/libperl5.22/changelog.Debian.gz and re-ran apt full-upgrade -f.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.