2

Everything was running smooth and fast till I updated my system. It is evident that the newest updates are causing this +2minutes boot time. suspicious boot times are enclosed in asteriks

systemd-analyze critical-chain

The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @18.892s
└─multi-user.target @18.891s
  └─getty.target @18.891s
    └─getty@tty1.service @18.891s
      **└─rc-local.service @18.880s +2ms**
        └─network-online.target @18.879s
          **└─NetworkManager-wait-online.service @12.743s +6.135s**
            └─NetworkManager.service @10.302s +2.439s
              └─dbus.service @9.724s
                └─basic.target @9.720s
                  └─sockets.target @9.720s
                    └─cups.socket @9.720s
                      └─sysinit.target @9.654s
                        **└─apparmor.service @8.608s +1.045s**
                          └─local-fs.target @8.606s
                            └─local-fs-pre.target @8.606s
                              └─systemd-tmpfiles-setup-dev.service @2.258s +1.379s
                                **└─kmod-static-nodes.service @2.147s +110ms**
                                  └─system.slice @2.128s
                                    └─-.slice @2.060s

lscpu

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 37
Model name:            Intel(R) Core(TM) i3 CPU       M 380  @ 2.53GHz
Stepping:              5
CPU MHz:               1466.000
CPU max MHz:           2533.0000
CPU min MHz:           933.0000
BogoMIPS:              5066.70
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              3072K
NUMA node0 CPU(s):     0-3
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt lahf_lm tpr_shadow vnmi flexpriority ept vpid dtherm arat

Yesterday though, the startup process wasn't slow as I described, and so it is now. I haven't updated or made any changes.

UPDATE: One out of two in every boot time is normal. Here's the processes' log for a normal boot time

graphical.target @20.069s
└─multi-user.target @20.069s
  └─getty.target @20.069s
    └─getty@tty1.service @20.069s
      └─rc-local.service @20.060s +2ms
        └─network-online.target @19.997s
          └─NetworkManager-wait-online.service @13.753s +6.243s
            └─NetworkManager.service @10.898s +2.854s
              └─dbus.service @10.274s
                └─basic.target @10.268s
                  └─sockets.target @10.268s
                    └─uuidd.socket @10.268s
                      └─sysinit.target @10.201s
                        └─apparmor.service @9.391s +809ms
                          └─local-fs.target @9.390s
                            └─local-fs-pre.target @9.390s
                              └─keyboard-setup.service @2.397s +1.450s
                                └─system.slice @2.395s
                                  └─-.slice @2.360s

Edit: you may like to use this sed -e 's/[0\]]{2}//' chain.art to make the chain log look better

  • Please provide a bit more information about the system you are using along with the os version – sissyphus_69 Nov 9 '17 at 8:06
  • I confirm this bug. Everything started with Linux 4.4.0-98-generic. Loki 0.4.1 Loki. After logging in, I lost all my "App settings" too, for example Chrome user or Telegram Desktop login. My chain: pastebin.com/6yDsrSay – Davide Nov 9 '17 at 17:27
  • I think he has our problem too: elementaryos.stackexchange.com/questions/13844/… – Davide Nov 11 '17 at 13:35
  • Indeed. What I find strange is that now everything isn't as slow as it is (it is still slow). I'll try to boot a couple more and see what happen. – egy Nov 11 '17 at 13:37
  • This thread is similar also: elementaryos.stackexchange.com/questions/10467/… – egy Nov 16 '17 at 17:30
1

This is a known bug in dbus.

Workaround:

sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.desktop.backup

More info: https://bugs.launchpad.net/elementaryos/+bug/1596377 or https://mail.gnome.org/archives/commits-list/2016-July/msg02793.html

| improve this answer | |
  • I have taken a quick look at both and they're relevant. Indeed, it's a dbus issue. I'll try the workaround later. Thanks :) – egy Dec 2 '17 at 15:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.