5

I can see I can set proxy's configuration for http, https, ftp, socks, etc. But I cannot set exceptions to this rules.

1

I am not seeing a way to add proxy exceptions to network config. I would recommend editing the /etc/environment file manually.

Launch an editor to modify the environment file:

sudo scratch-text-editor /etc/environment

Add another line to the file for domains where you don't want to use a proxy by setting the no_proxy variable. For example:

no_proxy="localhost,127.0.0.1,localaddress,.localdomain.com"
  • I had done this already, but was kinda wondering at what moment does this file gets read by the system. – Marcel M. Aug 19 '15 at 18:14
  • 1
    @MarcelM. /etc/environment and the per-user equivalent ~/.pam_environment are read when you log in. – Gilles 'SO- stop being evil' Aug 19 '15 at 20:22
  • Although it should work immediately, a reboot may sometimes(rarely though) be necessary to make it work. – user922 Aug 20 '15 at 0:15
  • 1
    FYI, I filed a bug to track this. I think it would be useful to add this to the graphical settings: bugs.launchpad.net/elementaryos/+bug/1486785 – zlalanne Aug 20 '15 at 0:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.