After official kernel update, my rt8188eu chipset was not working on desktop machine. There was no wifi option in network settings.

So I downloaded the driver from GitHub and compiled myself, and it worked. But if I turn off wifi from the the panel of elementary OS (right side), I can't turn that back on from GUI, I need to execute "nmcli radio wifi on" each time. (This issue existed on stocked kernel that was packed with Elementary OS too, but in my laptop, no problem at all)

My questions are -

  1. " Do RT8188eu chipset drivers included in Linux Kernel ? I don't think so, I tried 4.10 with headers too. "

  2. The graphical glitch in WiFi toggle button is an old but still unsolved issue. I have no idea which components are responsible for it. (I tried Arch Linux+GNOME and Linux Mint 18.1, and problem is not there.)

1 Answer 1


Firstly, try downloading UKUU (the Ubunutu Kernel Update Utility), and you can try to boot into some different kernels with minimum hassle. I successfully use 4.13.10. For 4.13 you would probably need this kernel patch, on top of driver.

Secondly, there might be other kernel modules that need to be enabled? ,

Finally, try filing an issue on the Github page: https://github.com/lwfinger/rtl8188eu/issues the fact you just need to run a command, as wifi radio is failing to switch correctly, sounds like something fixable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.