When I was evaluating Elementary as my primary os, i installed the os on my ssd, and then hooked up an external as my storage drive. When I decided this is the OS that I want to use primarily going forward, I bought another 1TB internal drive and cloned my external using PV. This has created a problem for scripts that I want to use at boot time that need to access data from that drive. (my wallpaper for a wallpaper changer script I run on boot in case you're curious).

Anyway, now my drive still thinks its an external in pantheon. See below: enter image description here

Now it is fine when I click on it, I can hear the drive "wake up" and finally, actually mount. But I need this to mount as an internal drive at system boot so I don't have to "wake it up" like this.

Can someone give me a step by step on this? I'll love you forever I promise.

1 Answer 1


I'm guessing there is just no fstab entry for your drive. I hope you are comfortable using the command line a bit.

All you want to do is find out the UUID of your new drive, and add an fstab entry

Step One

Find the FSTYPE and UUID of the partition you want to mount

# The df command will give you a list of mounted drives
# You want to retain the Mounted on entry of your partition for unmounting later 
df -h

# lsblk will give you the UUID for adding to fstab

Step Two

Make the folder that will be your mount point (you need one), as an example: mkdir /media/storage will create a folder media/storage which could be the new root of your drive

Step Three

Unmount the partition you want to load up at boot (the Mounted on entry from df -h, such as /mnt/external or something like that)

umount /media/drive # Replace /media/drive with Mounted on folder

Step Four

Add your drive to fstab.

Build your command:


Here is an example:

UUID=d2d0d4f6-7947-455e-a3d1-d73183f0afac /media/storage           ext4    defaults        0       2

To install the drive properly run this (replacing with your command):

echo "UUID=d2d0d4f6-7947-455e-a3d1-d73183f0afac /media/storage" | sudo tee -a /etc/fstab

Step 5

Try mounting your drives

mount -av

If this works, your drive should now be available, if not you need to do this:

Fix if mount didn't work

sudo nano /etc/fstab

Remove the final line (but not other ones), which should contain the text you created

Try again from the start.


Double check that /etc/fstab does not contain a different line that references the same drive partition.

If you have problems please comment here. It's best not to restart your machine until mount -av runs successfully.

Let me know how it goes!

  • This worked great! although for some reason Pantheon still shows an eject button next to the drive and its still named "External" there. i.imgur.com/5lAeeHf.jpg Other than that, it provided a little bit of tweaking (I had to fix my userdirs.dirs so it points pictures/documents/Downloads to the new folders I moved from the home directory) So yeah, this worked great. Any idea how I stop Pantheon from putting that eject button there?
    – Cerebrix
    Commented Nov 1, 2017 at 20:01
  • Is there another entry in fstab for the same drive? Commented Nov 1, 2017 at 20:54
  • Also in the GUI for disk settings there might be a "Show in user interface" checkbox. I'm out and about so I can't check. The fact it shows in the UI isn't a problem though. You can unmount and mount internal partitions too, they just don't show in the file manager as removable. Commented Nov 1, 2017 at 20:59
  • Nothing in my fstab. see below. I have no idea where to look in the gui for disk sct
    – Cerebrix
    Commented Nov 2, 2017 at 1:11
  • There is a utility called Disks you should find in applications. If you click on your drive, and click the settings gear wheel, it has the checkbox Show in User Interface Try that ;-) Commented Nov 2, 2017 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.