2

Everytime I edit something in Scratch, it creates a file with the same name ending with a tilde (~).

How can I prevent this? This is really annoying while working with Git.

3

Although not a direct resolution to your problem, you should probably add tilde files to your .gitignore file anyways. This will prevent git from even noticing them, and should solve your problem.

You can read about the format and contents of the .gitignore file here.

Best of luck!

  • Thanks for this answer, this solved the problem. I've made a global .gitignore file with '*~' in it. – thomasberends Nov 1 '17 at 19:45
  • Glad that I could help out! – Ben Foote Nov 2 '17 at 14:57
1

This is because you have the file open and are currently editing it. Once you close Scratch this should disappear.

0

You won't see the tilde file if you disable "show hidden files" in Files or disable "save files when changed" in Scratch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.