I am trying to run Yakindu (https://www.itemis.com/en/yakindu/state-machine/) on elementary OS.

But as soon as I start it the GUI starts slowing down until it is not responding anymore/is frozen.

I tried it on 2 different computers running Elementary OS (a desktop and a laptop: different CPU, different GPU) with the same result.

Note 1: Yakindu is based on eclipse and eclipse is running OK on Elementary OS.

Note 2: Yakindu is running OK on an Ubuntu system.

Note 3: When Yakindu is started the Xserver seems to be getting a lot of CPU load


1 Answer 1


Ubuntu (and thus eOS) has issues running GTK3 applications (Eclipse uses GTK3, and as a consequence Yakindu probably does too.)

In Eclipse's case, this is solved by adding this to the eclipse.ini file

On the line before

--launcher.appendVmargs, you add:



I would expect a similar file to be part of your Yakindu installation, could you search for it, make the appropiate changes and try to run it again?

  • 1
    Your are right. I added the 2 lines on the SCT.ini file and everything seems to work now. Thanks
    – JC Dubois
    Commented Oct 27, 2017 at 19:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.