So, the system is telling me that important updates were found, but every time I run sudo apt update I get these errors.

 Err:19 http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu xenial Release
404 Not Found Reading package lists... Done
W: https://download.01.org/gfx/ubuntu/16.04/main/dists/xenial/InRelease : Signature by key 09D6EF97BFB38E916EF060E756A3DEF863961D39 uses weak digest algorithm (SHA1) E: The repository 'http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu xenial Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

I tried everything but couldn't find a solution, help please.

up vote 0 down vote accepted

It seems that you have added this PPA manually. The error says that this software source has no build for Xenial. You should remove this PPA again. Alternative PPA (but is not recommended and supported by elementary's support) would be the PPA from Canonical Kernel Team.

  • Thanks! What about this one? W: download.01.org/gfx/ubuntu/16.04/main/dists/xenial/InRelease : Signature by key 09D6EF97BFB38E916EF060E756A3DEF863961D39 uses weak digest algorithm (SHA1) – hopeless Oct 26 '17 at 1:30
  • If you don't know why you want to use this repository, remove it, too. Though, this is only a warning about security. Functionality should not be limited... – bigbang Oct 26 '17 at 6:53

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.