0

I've installed Elementary 0.4 Loki on my Asus N752VX a couple of days ago and the system can't shutdown properly. When I click the shutdown button my mouse cursor just disappears leaving the "Are you sure you want to Shut Down?" dialogue open and the system becomes completely unresponsive. I've tried opening a terminal (super + T), pressing the delete and escape keys as well as ctrl + alt + function keys and none of these do anything. Only thing I can do is hold down the power button until the laptop is off. I've looked around and tried editing the /etc/default/grub file to get the

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

line to say

GRUB_CMDLINE_LINUX_DEFAULT=""

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

or

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq acpi=force apm=power_off quiet splash"

and none of those helped. Running sudo shutdown -r now leads to the same results. The set up is dual boot with Windows 10 and my kernel version is 4.10.

  • Hi, have you tried to rebuild grub.cfg after you modified /etc/default/grub? "grub-mkconfig -o /boot/grub/grub.cfg" or the actual path to grub.cfg – Атанас Минков Oct 22 '17 at 15:25
  • Thanks a lot for the reply! This partially helped. As long as GRUB_CMDLINE_LINUX_DEFAULT is set to "quiet splash nomodeset" the computer shuts down properly after rebuilding grub.cfg and (force) restarting it. However it is unable to recognize my monitor and I can't get a resolution higher than 800x600. – polaris6933 Oct 22 '17 at 16:34
0

After a lot of digging and trying several other distros (Ubuntu 17.10 and Mint 18.2 which exhibited similar behaviour) it turns out the problem is related to the video card and, most probably, the Optimus technology. Enabling the proprietary Nvidia driver seems to fix most of the issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.