3

I downloaded pdfshuffler and radiotray from the Software Center, but they won't open in elementary. When I open either of them in Terminal, I get the error discussed here: GTK-error while running a pyplot-application The answer in this question didn't help me because it sounded there like the program still ran but showed the error in the Terminal, however in my case, the programs don't run at all.

I did some reading and it may be a gtk2 conflict?? Can someone shed some light on this and if there is a possible fix. Both of these programs ran fine in Ubuntu 14.04. THANKS

6

pdfshuffler:

Looks like there is bug report about pdfshuffler on freya :

Launchpad Bug Report

As for the error you are getting :

Gtk-Message: Failed to load module "pantheon-filechooser-module"

A bug report was filed and fixed. pantheon-filechooser-module-bug-report

You might have installed an older version of the application. Try re-installing the application, but from this link:

pdfshuffler for ubuntu 14.04

Download the package according to your system architecture.

According to this post the user is having a similar problem with a different application, and updating the application to the latest one fixes the problem.

Now, if you are getting an error about not finding a package named poppler:

You need to install poppler python bindings, which will be pypoppler and pypdf(recently changed to pypdf2).

Ohh, and also remember, not to run pdfshuffler as root.

Reffer to these if you want a detailed answer to the poppler problem.

poppler not found solved

could not import pdfshuffler debian bug report

For a different approach to this problem, check if you are getting this error:

Gtk-Message: Failed to load module "canberra-gtk-module"

If you are, then you may find help here: failed to load cranberra-gtk-module

or here : cranberra-gtk-module solved

Now, for the other part of the problem, radio tray:

I hope you will find help in either of these links. Both show how to make radio tray work in elementary:

Radio tray stopped working in freya

or

Radio tray not working

Hope these links might help you find what you need.

  • 1
    Thank you so much for taking the time to compile all this for me!! I really appreciate it!!! – kingogames Aug 18 '15 at 15:14
  • The only error I am still getting with pdfshuffler is the pantheon files one. How can I install that fix? I ran a dist upgrade but it is still doing it. – kingogames Aug 19 '15 at 2:18
  • @kingogames I have updated my answer with new information. Please try it out, and let me know if you are still experiencing the problem. – godslayer_69 Aug 19 '15 at 7:58
  • (great name btw). I got the same error: anthony@anthony-Aspire-S3:~$ pdfshuffler Gtk-Message: Failed to load module "pantheon-filechooser-module" Error: Could not import pdfshuffler Cause: No module named poppler – kingogames Aug 22 '15 at 1:06
  • Updated my answer. You need poppler python bindings for it to run. Do remember, not as root. – godslayer_69 Aug 22 '15 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.