elementary OS 0.4.1 Loki

I am trying to create a keybinding (like CTRL+Z) to a script file, but it never executes.


System Settings -> Keyboard -> Shortcuts -> Custom -> Add

I have tried: 1.) full path, /home/me/myscript.sh, 2.) bash /home/me/myscript.sh 3.) copying the script to /usr/bin

Nothing seems to work. I have create other custom bindings to things like xkill and it works fine, just cannot get it to run a script file.

Any help is appreciated :-)


I found out that it was actually running the script but not showing the terminal. I validated this by launching chrome from inside the bash script -- so that was the issue.


Add '-c' to the bash command. This worked for me:

bash -c <full path to script>


bash -c /home/me/myscript.sh
  • Thank you but i found out the issue, it works fine with or w/o -c -- it was just not showing the terminal.
    – schmoopy
    Oct 23 '17 at 2:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.