Installed Windows 10 normally in UEFI and then Elementary OS Freya. During installation I have created swap and root partitions.

Now I can't get GRUB to show up. What I've done to try to fix this problem:

  • I ran Boot Repair (Recommended repair) on live elementary (secure boot off).
  • On windows command line, entered: bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi
  • Disabled fast boot in Windows

Boots straight to Windows 10.

Here's the BIOS settings:

enter image description here

Maybe it's worth mentioning, the laptop is an Acer ES1-512 with latest 1.15 BIOS.


4 Answers 4


I installed easyBCD in Windows 10 and added an entry for elementary OS. Then I disabled grub on the elementary side. Now, when I boot up, I choose elementary or Win 10 from the Windows boot manager.

Then on the elementary side, edit /etc/default/grub Find this line: GRUB_TIMEOUT=10 Change the value to 0.1 (Zero didn't work on mine, it still waited 10 sec.)

This won't disable grub per se, it just times it out real quick. Maybe not the most elegant solution, but it may get you where you want to go.


Try reading the following blogs, might find some help there.

win10 preview & ubuntu dual-boot tip

win10 & ubuntu14.04 dual-boot


This did it for me. Although I had to run boot-repair twice.

Cannot boot Freya after installing alongside Windows on UEFI


Boot-Repair should fix it, this happens with every Linux and every Windows, even TinyCore (and that's the only one that you can't boot to in the bios, however core and tinycore have restore settings so USB = boot, just some useless information here.)

  • Answers should provide a fix to the problem indicated in the question. Also please do not deviate from the topic. Information that doesn't refer to the context, is not useful. Commented Sep 20, 2015 at 6:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.