2

I recently upgraded Google Chrome from version 61.0.3163.100-1 to version 62.0.3202.62-1 and now there are no window buttons (close, maximize) visible when the browser window is maximized.

Here's the top part of the window when it's not maximized: Google Chrome unmaximized

And here's how it looks like when the window is maximized: enter image description here

I'd also like to note that I am using Google Chrome not Chromium.

Has anyone of you encountered this problem, or (even better) know how it could be solved?

I haven't had the chance to try this version of Google Chrome on distros other than elementary - information from users of other distros would be appreciated. If this issue is not specific to elementary, then it would probably be better post this question to AskUbuntu.

Thanks in advance!

  • What them are you using? And have you selected "Use System Title and Borders" in the Chrome settings? And lastly, is the the Stable Chrome version? – Sean Patterson Oct 18 '17 at 15:18
  • I use the "classic" Chrome theme (not the GTK+ one). "Use system title bar and borders" is not selected. I realize that enabling it solves the problem, but I don't want to lose that much vertical screen real estate (plus it looks ugly imo). Lastly, yes, it is the stable Chrome version. – Magnus Teekivi Oct 18 '17 at 15:30
  • Just a suggestion, running the Dev version might solve your issue. They have modified the way Chrome handles titlebars in that build. – Sean Patterson Oct 18 '17 at 15:59
  • 1
    I found this reddit topic which addresses the problem I described. It turns out to be a known problem and an issue report is already filed to Chrome developers. – Magnus Teekivi Oct 18 '17 at 18:10
  • Version 63 of Chrome has this issue (kind of) fixed. Most of the time, the window buttons are there when the window is maximized. But at times, the buttons are not there, and I need to unmaximize and then maximize the window to make the buttons appear again. – Magnus Teekivi Jan 7 '18 at 14:14
3

It has a workaround running chrome with env XDG_CURRENT_DESKTOP=GNOME via terminal. Here's a screenshot of that.screenshot of Chrome 62 with window controls in maximized mode

It is possible to alter Google Chrome's environment via changing the /opt/google/chrome/google-chrome file (which is actually a shell script) so that the window controls problem is fixed for every opened Chrome instance. The last few lines of this edited file would look something like this:

# Temporary fix for maximized window controls absence
export XDG_CURRENT_DESKTOP=GNOME

# Note: exec -a below is a bashism.
exec -a "$0" "$HERE/chrome" "$@"
3

This is specific to Elementary. This is due to a bug I fixed to show the app indicator in the status bar. The side effect of the implementation detail, was it caused the buttons to get removed when maximized. Knowing the GTK work was going on (which is now in v 63) to make this work as expected anyways, I didn't raise any flags since it is just about 6 weeks that this would be in the wild.

There is no way around this while having system titlebars off. If you use the system titlebars, then this should work fine while just eating a little extra space on most monitors.

Version 63 (current dev channel) has this issue fixed. I'm running it right now and the previous update or two brought the buttons back when maximized. Even when not using the system titlebars.

  • I had install the version 63 (beta) and the controls appear this way:(imgur.com/Lkd8jZU) very different of default style (imgur.com/e1LvD4j). Any way to solve this? – Marcelo Rodovalho Oct 28 '17 at 18:43
  • For that difference you just need go to into the settings and switch to the classic theme from the GTK one. – Garbee Oct 28 '17 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.