0

after updates from 2017-10-16... enter image description here

...my system won't boot anymore with following errors... enter image description here

I tried to boot into recovery mode, but after typing my username the system does not prompt for password... enter image description here

...it simply returns to login prompt again enter image description here

Is there any other way to rescue the system from complete re-installation in this hopeless case?

0

Solution found!

  1. Boot from Live USB
  2. mkdir /mnt/recover (create a temp folder)
  3. mount /dev/sdc1 /mnt/recover (mount my root fs to temp folder)
  4. Tried chroot /mnt/recover (to become root of my mounted root fs) but received an error that there is no bin/bash folder
  5. Copied the bin folder from Live USB to my /mnt/recover
  6. chroot /mnt/recover finally did work
  7. sudo apt purge lightdm (to remove the faulty lightdm packages)
  8. sudo apt install lightdm (to install lightdm anew, but received an error that repos couldn't be reached)
  9. Restarted the machine and booted to my system, without lightdm it booted in text mode. But I was finally able to log in normally!
  10. From here simple sudo apt install lightdm did install the display manager.
  11. Reboot, and my system is back! enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.