1

I have a serious issue that I don't understand. When I start my computer elementary won't open the graphical window to log in and instead it starts a tty terminal. To get the graphical login window I have to login in the tty and run

sudo /etc/init.d/lightdm stop
sudo /etc/init.d/lightdm start

Sometimes it takes a few minutes (about 2min max) before it shows the dock and the menu-bar.

I didn't do anything to have this problem. Just some regular updates...

Update : thanks to @bigbang it's resolved by running this command :

sudo dpkg-reconfigure lightdm
  • Could you try to enter in terminal: dpkg-reconfigure lightdm? What results in typing "cat /etc/X11/default-display-manager" in terminal? – bigbang Oct 10 '17 at 13:49
  • When i run dpkg-reconfigure lightdm I have this output : ** insserv: warning: script is corrupt or invalid: /etc/init.d/../rc2.d/S01shm_load insserv: warning: current start runlevel(s) (empty) of script lightdm' overrides LSB defaults (2 3 4 5). insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script lightdm' overrides LSB defaults (0 1 6).** And when I run cat /etc/X11/default-display-manager I have : /usr/sbin/lightdm – Gatsby Oct 12 '17 at 16:08
  • I created my suggestions as an answer, please mark the answer as solved. Thanks! – bigbang Oct 13 '17 at 11:14
0

You can try to resolve the problem by typing:

sudo dpkg-reconfigure lightdm

Perhaps there is a confusion between display managers. To show the current one, type:

cat /etc/X11/default-display-manager

For other solutions, you have to investigate further.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.