1

Applications menu loads slowly at first use (first boot). Then, at second use, it responds quickly at scrolling through apps. Is tit a bug or do I have a slow computer? 4 GB RAM, Quad-Core AMD A8-6410 APU with AMD Radeon R5 Graphics. It happened in Freya, too, same PC.

1

It's a known issue: https://github.com/elementary/applications-menu/issues/47
Should have been fixed with: https://github.com/elementary/applications-menu/pull/48
Seeing that the latest applications-menu release was in Sep 26, 2017 this fix hasn't been released yet, see:
https://github.com/elementary/applications-menu/releases

If you can figure out the right repo, it's always interesting to check the existing issues.

1

If other operations are slow then it may be an information bottleneck for your machine. I had a 2011 mac mini with an i5 and 16gb of ram, but the HDD was 5200 RPM and became the bottleneck for that machine. With 20 icons on the desktop and plenty of docs on the desktop, it had a slow initial boot but was fine once everything loaded. I have only deployed Loki on SSD machines with DDR4, some have even been M.2 SSDs, I have never experienced an App menu hang up on them, they are as fast as I expected them to be. Given that you may experience the same behavior in other data-heavy-loading scenarios I think it is safe to say there is a bottleneck for your machine.

1

I also noticed it gets slow.

Some facts so far:

1.I tested it on 3 different machines, i3 All-in-One Desktop, i5 Laptop and top-notch i7 Workstation - same deal on all of them - the menu stutters for a second and then works smoothly...untill I launch it couple minutes later after doing something else. The question is, what triggers the stuttering?

2.Tested both on free and proprietary drivers from nvidia - same stuttering.

3.Tested on 3 different resolutions HD, FHD and UHD - same deal.

4.Tested on different hardrives, including SSD's - same deal.

Definatley a software issue.

Still hunting...

EDIT:

One trigger found:

Menu appears to stutter after checking any other place on the wingpanel first (like calendar, volume etc.).

  • 2
    Seeing the following fix I would recommend compiling the latest version of the applications menu and seeing if that fixes the issue for you. github.com/elementary/applications-menu/pull/48 – Peter Uithoven Jan 16 '18 at 14:49
  • Compiling the latest version indeed fixes the problem for me. Now Slingshot handles scrolling between app pages differently.THX! – DanyGee Jan 16 '18 at 15:34
  • Awesome! Hopefully we'll see a release soon. – Peter Uithoven Jan 16 '18 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.