I have tried various (almost all) nvidia proprietary drivers on my machine and vsync issue is still persisting. Nouveau drivers in not an option as I want to SVP (https://www.svp-team.com/wiki/Main_Page) for playing videos which require nvidia proprietary drivers. Please help if someone has sorted out this problem in Loki or any previous version of elementary OS. Any advice will be appreciated.

1 Answer 1


Assuming that you're using prime profiles and not bumblebee, you're wanting primesync described here: https://devtalk.nvidia.com/default/topic/957814/prime-and-prime-synchronization/

To easily enable this in Loki, make sure that you have the latest OS updates and proprietary Nvidia drivers enabled.

Do the following steps from the terminal:

1.) sudo nano /etc/modprobe.d/nvidia-graphics-drivers.conf

2.) Change the line that says "nvidia-drm.modeset=0" to "nvidia-drm.modeset=1"

3.) Press Ctrl+x to exit and press "y" to indicate that you like to save your change.

4.) sudo update-initramfs -u

5.) Reboot your computer.

These steps will enable primesync through the Nvidia proprietary drivers. If you have issues, just change modeset back to 0 and update your initramfs again!


If you have further issues, you can try updating your intel graphics firmware for Skylake, Kabylake, or Broxton: https://01.org/linuxgraphics/downloads/firmware

If you're still having issues using the power-saving, intel GPU under the prime profiles, you can try changing your ACPI OS Interface string to make your bios/efi DSDT behave a little better under linux.

1.) sudo nano /etc/default/grub

2.) Change GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="acpi_osi=" If that doesn't work, try GRUB_CMDLINE_LINUX="acpi_osi=! acpi_osi=\"Windows 2009\""

3.) sudo update-grub

4.) Reboot

When all else fails, reinstall your nvidia graphics package:

sudo apt --reinstall install nvidia-(your version here: i.e. "nvidia-375")



  • Tried it but with no luck.. lightdm crashes as soon as I login and even login screen comes in half resolution of the screen. Commented Oct 2, 2017 at 8:19
  • Neo, I screwed up and named the wrong conf file. XP If you created a "nvidia-graphics.conf" delete it, and instead edit "nvidia-graphics-drivers.conf". Technically the actual file exists elsewhere and /etc/modprobe.d/nvidia-graphics-drivers.conf is a symlink, but it's easier this way. =] Be sure to "update-initramfs -u" again after making these changes. Sorry again!
    – Reed Love
    Commented Oct 2, 2017 at 15:42
  • Will update when I get back to my laptop. Commented Oct 2, 2017 at 15:47
  • Any luck getting it to work?
    – Reed Love
    Commented Oct 4, 2017 at 1:14
  • I tried updating the microcode for my cpu but it doesnt seem to work, I didn't get the troubleshooting part as my cpu is core i5 2450M i.e. sandy bridge whose firmware was not there in your provided link Commented Oct 7, 2017 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.