I'm currently running Elementary OS Loki 0.4 on my Dell Inspiron 5566, and I just ran into an issue where I simply can't edit the names of any file or folder if I use the pre-installed pantheon-files app.

I tried the Nemo/Cinnamon file manager, and file renaming works fine in that app. I was about to just switch over to that since it seems like a more robust app than pantheon-files, but Nemo also gave me one major issue. Whenever I launch Nemo, an un-interactive Desktop window shows up and doesn't go away until Nemo is completely closed. I've tried searching to see if there's a solution to this, but I couldn't find anything.

I've tried uninstalling pantheon-files from the app store and reinstalling it. That didn't help. I've tried removing it with the --purge function from the Terminal, and reinstalling it, and that didn't work either.

At this point, I just want one of them to work without having to reinstall the entire OS. The only thing I know for sure, is that it was working fine before I tried installing emulationstation, and as I was installing it, I went to my pantheon-files to create some directories, and that's when I noticed it didn't work. I'm not sure if something I did while installing emulationstation broke it, but that's when I noticed it.

Let me know if you need any more info from me.

  • can you try to explain more specifically what you are doing and whats (not) happening? (Rename via right-click and it's greyed out), using F2 and nothing happens?)
    – Eric G
    Commented Sep 27, 2017 at 8:39
  • Sure. I was only trying the right click > rename option, but I just tried F2 and that exhibits the same behavior. Basically, if I right click and hit rename, the folder will go into edit mode like normal. I can type what I want in fine, but the moment I hit enter or click away, the folder exit's edit mode and nothing happens. The name just stays what it was before I tried to edit it. Commented Sep 27, 2017 at 9:35
  • Could you just confirm the location and type of file you are trying to rename? Is there any emblem on the icon? It sounds like you are not getting any dialog saying the file cannot be renamed? I am not having any trouble renaming local files with the latest (unstable) version of Files. Commented Sep 27, 2017 at 16:33
  • Have you tried the effect of uninstalling or disabling emulationstation (and rebooting)? I have checked with a "vanilla" install of Loki with Files 0.3.5 and renaming was working. It seems unlikely that there is a global breakage in file renaming in Files, but certain files may not be renamable depending on location or permissions. Commented Sep 27, 2017 at 16:49
  • Yeah, from what I can tell, it's pretty much any file or folder that I try to edit. I discovered it by trying to create a "roms" folder in / and noticing I couldn't change it from "New Folder", but I tried rename a .jpeg in my download folder and that didn't work either. I tried renaming some of the rom files, nothing. And yes, I can confirm, I don't get any kind of error dialog, or any indication that something has gone wrong. The edit I make simply aren't taking. I did indeed uninstall and remove emulationstation through the Terminal and reboot. That didn't seem to have an effect. Commented Sep 27, 2017 at 18:28

1 Answer 1


I have this problem also. I've had this problem across 3 installations of Loki.

The problem is that pantheon files doesn't seem to save the new name without you pressing enter.

So long as you press enter after typing the new name it works, but if you click outside of the file you're renaming it fails.

  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review
    – r3bl
    Commented Feb 9, 2018 at 23:37
  • The answer is to press enter after typing the new name of the file. Commented Feb 12, 2018 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.