3

i've installed libinput-gestures to get OS X-like gesture for switching workspaces. Sometimes some previously copied text gets pasted randomly in the current workspace, after the three finger swipe up or down gesture. That's extremely annoying.

I searched a lot but didn't find any solution. I own a Dell XPS 13 9343. How can i disable the three tap paste gesture?

1

A relevant issue on a similar topic, the middle mouse button: https://github.com/elementary/default-settings/issues/5

You might want to start a discussion on whether this is expected behavior.

1

If you use Gnome, install gnome tweaks, go to keyboard and mouse section and disable Middle click paste

0

Run synclient -l | grep TapButton3 in terminal. You will see that TapButton3 = 2. We want to disable this. Run synclient TapButton3=0 and it should work. It is only temporary for that session though.


A permanent solution is a bit messy.

  1. We need to make sure that gnome settings daemon is not messing with our settings. To do that go to org>gnome>settings-daemon>plugins>mouse and dismiss the active option.

  2. Make a directory /etc/X11/xorg.conf.d (if it is already not there).

  3. Copy /usr/share/X11/xorg.conf.d/70-synaptics.conf to /etc/X11/xorg.conf.d/.

  4. Add Option "TapButton3" "0" to /etc/X11/xorg.conf.d/70-synaptics.conf in Section "InputClass" and Identifier "touchpad catchall".

  5. To enable natural scroll, you will have to add Option "VertScrollDelta" "-77" and Option "HorizScrollDelta" "-77" as well. -77 is just a negative integer with appropriate scroll speed which may differ for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.