0

I have a headset, but it's mic is not of good quality and I want to use headset's headphones while using laptop's internal mic. When I plug that headset, internal mic (as well as internal speakers) is automuted and there is no such an option in audio input parameters.

  • So internal mic disappears in input settings when you plug in your headset? – Eric G Sep 21 '17 at 7:26
  • @EricG, yes. I would like to see both of options (internal and headset's mic) in these settings. – Artyom Ilyin Sep 21 '17 at 8:15
  • Just have seen that it's the same for me...Strange – Eric G Sep 21 '17 at 9:15
1

A workaround for me is using pavucontrol. Install it via AppCenter or

sudo apt-get install pavucontrol

Start it and choose your internal mic. Try to mute your external and unmute your internal mic via the button in the screenshot. enter image description here

| improve this answer | |
  • In the list of input devices I have "Internal mic (unplugged)". So when I choose it, the levels indicator still shows headset mic's signal. – Artyom Ilyin Sep 21 '17 at 10:06
  • I updated the answer, does that help? – Eric G Sep 21 '17 at 11:26
  • No, it didn't. I did exactly what you wrote and still my headset mic's signal is active, not internal mic's. Is it working for you? I remember on Windows there was a checkbox in Realtek HD Audio Manager, something like "Split audio devices when headset plugged". I need something like that here. – Artyom Ilyin Sep 21 '17 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.