0

I've installed the latest version of the Arduino IDE (1.8.4) following the instructions on the Adafruit website here:

https://learn.adafruit.com/adafruit-arduino-ide-setup/linux-setup

I connect my Pro Trinket board, but the Port menu is disabled, so I am unable to communicate and download a sketch.

I've also tried to run Arduino as root with gksudo, but I get the error:

(gksudo:6222): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

Suggestions?

1

I did more research and discovered that the Adafruit boards like the Trinket, Pro Trinket, Gemma, etc. do not show up in the serial port menu when connected via USB. You select the proper board, set the Programmer option to "USBtinyISP" then press the reset button on the board to enter bootloader mode and upload the sketch.

The older tutorials Adafruit and Arduino websites all mention selecting the connected board from the Port menu. This is still true for boards with USB chips like the UNO. I was way over thinking this. Sometimes the answer is so simple it seems it can't be correct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.