0

Let's make it quick. I have bought myself an old Dell Optiplex 780 with the following specs:

-Core 2 duo E7300

-4Gb Ram ddr2

To make it slightly "spicier"(playing on the league we're playing), I have thrown in the following components.

-Samsung 850evo 250Gb (used)

-Radeon HD4550 512mb ddr3 (display port, dvi)

-(On its way) Core 2 duo e8400, 5 bucks

And , of course, Elementary OS freshly installed which make the old bastard run as if it were on fire.

So here is mi issue. Can't get audio from the radeon card. Sound on system settings does not give me any additional options to choose from. I got into alsa mixer and enabled every single option. Nothing happened. I also added my user to the audio group(thing seems to have worked for some people). Nothing happened. Tried to download amdgpu pro but OS is not compatible and I'm not even sure this card would support the program.I have tried to check if there were any drivers for the audio chip (mobo), but only for windows. The thing is, I have reached my personal wall and can't find any solution to this issue, not even googling up as good as i can. If you had any solution or want me to try anything, please let me know.

Thanks

0

Okay.

1.) This was also a problem on Windows with these cards. I had a Radeon HD5750 and ran into this way back when. Eventually AMD fixed it in their drivers.

2.) I have no idea if that fix made its way to Linux or if it was a problem then.

3.) I have a potential fix, but I no longer have my card to test the HDMI audio out of and confirm it with you.

Give this bad boy whirl:

sudo apt-get update

sudo apt-get install software-properties-common

sudo apt-get update

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt-get update

sudo apt-get upgrade

This updates the video drivers.

  • Hi Eosdude. I have tried your potential fix but does not seem to work for me. When I list playback devices i only get the ones related to Intel analog devices ad1984a, the chip, and we don't get any further. There could be some sort of incompatibility... I'll keep searching. Thanks for your effort! – Coco Team Sep 13 '17 at 15:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.