0

I'm trying to solve the problem on How to type @ on a MacBookPro 2.1 but Keyboard in settings doesn't show an Options button like pictured on the screenshot.

What workaround is there to this issue?

  • Does the option exist under Keyboard -> Layout -> key to choose 3rd level? – Eric G Sep 7 '17 at 12:58
  • There is that option, but no left alt choice, so I used 'cap locks' + 2 (I'm on a Belgian keyboard on that machine). It produces @ – Lurch Sep 7 '17 at 18:20
0

In Loki 0.4.1 to enable to type @ on a MacbookPro 2,1 in Keyboard -> Layout -> key to choose 3rd level's choices did not include 'left alt', then the issue can be solved attributing it to 'caps lock', providing I'm using the GUI a lot I'm not using 'caps lock' frequently at all, so it's a working choice.

0

It should be possible to put it on Left-Alt like this: open terminal and put:

sudo dpkg-reconfigure keyboard-configuration

An setup starts with a Keyboard-configuration, the 4th screen is the 3rd-level option for me, I was able to choose left Alt here (not on a Macbook) Finish the setup than put:

service keyboard-setup restart

And it should work!

PS: Sometimes this change isn't permanent (gone at restart), write back if that's the case.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.