1

Had to remove all of the Power settings related to resume (to 'do nothing') on my machine due to suspend not waking machine properly. Screen remains black.

Note: sometimes MacOS SnowLeopard did have the issue that the screen did not wake, but a re-suspend re-wake did solve the matter everytime.

Using loki 0.4.1; graphic card is ATI Mobility Radeon X1600 - does it has to do with installing the proprietary drivers?

1

The issue is now solved: first I followed these two tutorials: 1. Improving Power management in EOS Freya (though using Loki 0.4.1) 2. Most Effective Ways to Reduce Laptop Overheating in Linux

Then I had a system update (drivers and intel chip) and since then resume from Suspend is going rather smoothly, and also lid close to Suspend goes fine too now.

|improve this answer|||||
  • Wow. Thanks for posting a fix. I had a hell of a time trying to track this stuff down and just gave up. It's appreciated! :) – Eosdude Sep 9 '17 at 19:53
  • I've noticed something related to DVD playback, though: when there's been a full screen playback, sometimes Suspend won't work properly and will do just like before, produce a black screen and require a force reboot.. – Lurch Sep 10 '17 at 6:34
  • Yeah, I don't bother with such things with computers. I just keep things on or off Linux or Windows. I don't do the suspend/hibernate options anymore. – Eosdude Sep 12 '17 at 19:26
  • System's just fine now, suspends comprehensively, including on lid close and resumes most of the time normally too. – Lurch Sep 12 '17 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.