0

Followed instructions on How to play a DVD on Loki, but the DVD video would just not play decoded. Sound is ok. But DVD menus and video content remain encrypted. Running loki 0.4.1 on a 2006 2,1 MacBook Pro 17", using VLC to read DVDs. De-installed Videos. De-installing libdvd-pkg, reinstalling, including VLC then rebooting doesn't solve the problem.

0

This answer will likely not help, but it is worth a shot.

To make movies and music work on Ubuntu run these commands.

sudo apt-get install ubuntu-restricted-extras libdvd-pkg

sudo dpkg-reconfigure libdvd-pkg

After that, since VLC is not working, try totem.

sudo apt-get install totem

reboot the computer, just for good measure, then try to open and play your DVD.

  • It does solve the issue completely. Totem has prompted to install two codecs, after first trying to run a DVD, and after rebooting a second time, now playback is fine. But I didn't identify which codecs these were, and VLC still can't play DVD's but that's secondary. Thanks a lot. – Lurch Sep 9 '17 at 17:12
  • I have not had that issue, but I do not use it much for actual DVDs. I will find a fix later this afternoon for you. – Eosdude Sep 9 '17 at 18:54
  • At the top of totem there is a "view" tab. Go ahead and play with the settiing there. Try the settings of "auto" and "zoom in" and it should fix it. Got it working for veggie tales :) – Eosdude Sep 10 '17 at 0:10
  • Thanks for the advice! I've checked with another DVD it was just one that had it's media cropped compared to the others. Any idea on how to enable the necessary codecs in VLC since the two other players work? – Lurch Sep 10 '17 at 6:32
  • Unfortunately not. I have not messed with VLC in a long while and don't know how to do things like that in Linux. – Eosdude Sep 11 '17 at 1:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.